Jump to content
  • 0
FaeGiN

Plex Media Server is forcing me to (finally!) upgrade my Firefox to the latest version!! Any ideas to avoid this? See much info inside...

Question

FaeGiN
Posted (edited)

I couldn't decide whether this should go into more of a general chat forum or here. As I do have a question, it went here, and I really would be so happy if ayone knew a way for me to go a different route to the one I feel I am having to go. Read on...

 

 

I love using an old version of firefox (v.43) with my favourite addons and have refused to update for ages. If it aint broke, dont fix it, right?! It really is a pity the browser creators do not agree with me on that because they have been determined to force people to update for years...each time some stubborn users refuse and are left behind (me!) as they keep finding a workaround to enable them to simply keep the browser in the very good and useful working state they were already using it in. (You know, the most efficient and streamlined usage of the software they had eventually arrived at.) Yet, for some unknown reason the creators will not allow that situation. They seem to feel it is better to get all users moved onto the new versions and keep them all in the updated path from then on. Not to forget that, because they changed the system, most older addons are no longer working and many authors simply never converted their addon to work with the newer firefox because it involved so much work and they also felt mozilla had shown them no respect for their work. And could leave them in the cold again in the future! Many ideas were even 'stolen' from addons and put into the new browser! Too right they didn't respect the addon authors! But that is another discussion hehe...
My point was that lots of addons did not work and never had anything like an equivalent one in the new browser and no settings in the browser either. I mean, how hard is it to have multiple row tabbed browsing built in? Yet still it is not an option and so i will miss my good friend Tab Mix Plus when I am forced to change to the latest browser version. That is only one of many addons I use and which really do add speed and efficiency to the browser and make it a real power user machine!


The time has arrived I am sad to say.
Time to be forced to upgrade and this time there is no workaround, no avoidance tactic I can come up with.

A url I need (and I mean i need because that url is the interface for Plex Media Server which we use in the house for nearly everything we watch) suddenly one day didn't load the expected Plex web interface, instead only loading up a Plex logo in the middle of the page and nothing else. No server, no access to settings, nothing but a logo.!?!

The only solution apparently is to use the latest browser versions! They are forcing me to update my browser!
After years of ducking and diving during each major browser overhaul and attempts by mozilla to convert me to an upgraded browser user and mess my addons up, etc, ...  somehow I always managed to get over it and avoid it only to now be beaten by a Media Server Developer! That is the reason I must upgrade!

A related, amusing little aside:
Even Plex's website doesn't let me login when using v43 of firefox! When I click sign in, up pops the sign in window which usually contains multiple options for signing in (like the one on imdb where it says by email, by facebook, by google logins etc etc) except it doesn't look like it usually did. The whole window is blank! So there is nowhere to put your login information and essentially it is impossible to log in. The irony! I wanted to login to talk about the inability to use or see the server interface in the browser, but I can't see any login in the browser either.

Aaarrrggghhhhhhhhhhhh! *pulls hair out*
*remembers he is bald*

*wonders where these clumps of hair in his hands came from?..!?*

😃😊🤔

I am also struggling to have roboform work these days too which is yet another story but basically I will be changing over to Keepass or Lastpass or something to use with the latest firefox when i install it. So if anyone is thinking of another workaround I could do, keep in mind that I seem to be forced to upgrade in order to have a working password manager too!! There truly is no hope is there ☹️☹️

...

I suppose the point of this -apart from just to rant about annoying software developers like Mozilla and definitely those plext'ds (!!) is to see if anyone here knows any way I can go about this differently and wind up keeping my legacy addons in whatever version of firefox I need to use with them!
I have already been using the Esr version which allowed my use of old addons for a longer time and still works great with them all but like I say, I need plex daily and cant access it.

I have run out of options...

Any ideas folks?

Edited by FaeGiN
mistakes

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0
wolfie
Posted (edited)

Probably not the answer you want to hear - I felt the same as you a while back, but then I took the plunge, updated Firefox and found replacement add-ons for all the ones that no longer worked.  Happy camper ever since.

Edited by wolfie

Share this post


Link to post
Share on other sites
  • 0
Karlston

My experience was similar. I held on and on and... until I found addons that could replace the ones I had.

 

Tab Mix Plus was one of the ones that had no replacement as an addon, but its author Aris developed some CSS that would do most of what TMP did, including multirow tabs, though it had some quirks with moving tabs. Not sure if that’s been fixed, I’ve been using a different method for multirow tabs.

 

Aris’s Github project is here... https://github.com/Aris-t2/CustomCSSforFx

 

For multirow tabs, been using (part of) this Github project... https://github.com/Izheil/Quantum-Nox-Firefox-Dark-Full-Theme

 

Didn’t use its installers, installed it manually because I had installed and was running two versions of Firefox, an old version with Aris’s CSS, but wanted to try out the Quantum Nox project’s multirow tabs (no problems moving tabs) in the (much) newer version. This way I could keep running my old version happily, and play with the new version until I got it working the way I wanted.

 

BTW, if you want to run multiple FF versions, make sure you do CUSTOM installs pointed to a different folder AND use a different FF profile for each install. Very important points! And first backup your current install folder and its profile, just in case.

 

Am happy to help more if you need it. Aris’s CSS is the easier of the two to get going.

Share this post


Link to post
Share on other sites
  • 0
FaeGiN
Posted (edited)

You see, this is why I only came here with this problem and skipped any other website online cos I knew that if there was any help to be had, I would find it here!

Thank you so much both of you.

@wolfie yep! i can tell, you understand that feeling...you hang on to the way you know it to work well and probably there's a bit of "software insecurity" in there (is that a thing lol...?! 😃😀😆) but we know the way we want it and feel we shouldn't be forced to change a thing if it aint broken! Thanks for the vote of support 😎👍

 

@Karlston

 Thanks a lot bud, I had thought about a second firefox, cos it is something i have used for years...you know, you set up the shortcuts on desktop with some switches and it enables you to have any number of profiles open at the same time wihout conflicting with each other ,  and keep separate your annoying teenage son (and wife's) firefoxes whilst you keep your poweruser one without them messing stuff up. What i did not think was that I could do what you say and have different versions on the PC at the same time. Cos i abandoned the idea when i realised -or so i thought- that i couldn't have different versions running at once.

So thanks for that! Great bit of info! 😎💥🤓

 

It probably won't surprise you to learn that, 'firefox hacker(?!) and messer-upper extraordinaire' me, I have already dabbled with that CSS code and some other I found by some random internet guy on some forum or other. Long time ago and I couldn't get my head around it when I kept messing it up and having weird results. I gave up, that's all I remember clearly about it 😀

 

You know, what I will miss is the many other features that tmp brought with it. Too many to list but if you were a longterm user you know what I mean...it was packed!

I have already found quite a few good replacements for others. Namely, one addon that enabled copy on select - like IRC - and that is something I am so used to, I think it ought to be a default option but no it isn't.  Well, there's an addon called Swift Selection Search which floats your SE icons on the page below or next to any text you select, you click one and it opens a new tab with that selected text into the search engine you clicked. Well what it also has in settings is COPY ON SELECT! woohoo! And some other wee useful options too so I highly recommend it.

Cheers 👍

Edited by FaeGiN
dribbling idiocy

Share this post


Link to post
Share on other sites
  • 0
FaeGiN

Just had another thought...

Virtual machine. I always have vmware systray icon there and can start up a VM whenever i need. I used it to have different versions if torrent progs going because some private sites insist on this version and others that versionso my sokutionbwas to have them both running the one they wanted, in different VM's and then I also had one on my actual PC for another site. Probably not the most elegant solution but hey, I had to use that CPU power up somehow apart from only when I was transcoding video, eh!

I just wondered if I could actually have a VM simply for Plex to have the latest of everything and be able to control it from latest ff in there. But keep my old version ff on the PC

Oh sod it!

As Wolfie said first reply to me, I MUST just bite the bullet and bloody move forwards eh. I can't stay stuck in the past forever. 😮🤐😆😃😀

Hehe

Oh well, thought I would share this brain fart with you.💭

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...