Jump to content
Sign in to follow this  
haris_sane69

Windows 10 autounattend.xml: Windows could not prepare the partition selected for installation

Recommended Posts

haris_sane69
Posted (edited)

Greetings everyone,

 

I'm trying to create an autounattend.xml for Windows 10 using WSIM to make the XML. I have the following issues:

 

1) PE ask me for language, even if it's set in the answer file which I changed from en-US to en-IN

2) PE ask for to select a disk, even if it's set in the answer file

3) After choosing disk 0 from the Windows Setup, I get this error: Windows could not prepare the partition selected for installation

However, when I reboot the system, the partitions are created as per my answer file and clicking next works without any error.  Problem is I want it to work on first boot, not on second boot.

One lasting thing after installation of Windows 10 when I checked disk management Recovery partiton is showing as RAW under File System instead of NTFS

https://i.postimg.cc/KvtLBfRB/Capture07.png

 

Here's the script: https://pastebin.com/RET8DBVQ

Regards.

 

Edited by haris_sane69
script added

Share this post


Link to post
Share on other sites
Coleo

Something is missing like the command convert GPT :)

Share this post


Link to post
Share on other sites
cyberloner

 <InstallFrom>

is not stated... else it will ask for language....... you need find full script and mod it...........

Share this post


Link to post
Share on other sites
haris_sane69
6 hours ago, cyberloner said:

<InstallFrom>

is not stated... else it will ask for language

okay I see but the main issue here is windows can't prepare the partition selected for installation on first boot

6 hours ago, cyberloner said:

you need find full script and mod it...........

This is the full answer file which I created by using Windows System Image Manager (SIM).

 

Regards

Share this post


Link to post
Share on other sites
Dodel
11 hours ago, haris_sane69 said:

Greetings everyone,

 

I'm trying to create an autounattend.xml for Windows 10 using WSIM to make the XML. I have the following issues:

 

1) PE ask me for language, even if it's set in the answer file which I changed from en-US to en-IN

2) PE ask for to select a disk, even if it's set in the answer file

3) After choosing disk 0 from the Windows Setup, I get this error: Windows could not prepare the partition selected for installation

However, when I reboot the system, the partitions are created as per my answer file and clicking next works without any error.  Problem is I want it to work on first boot, not on second boot.

One lasting thing after installation of Windows 10 when I checked disk management Recovery partiton is showing as RAW under File System instead of Basic

https://i.postimg.cc/KvtLBfRB/Capture07.png

 

Here's the script: https://pastebin.com/RET8DBVQ

Regards.

 

 

Have a look here:

https://community.spiceworks.com/topic/1856912-wds-unattend-xml-for-uefi-not-wiping-disk-and-crashes

and

https://social.technet.microsoft.com/Forums/windowsserver/en-US/477f8d72-06dc-43b1-96f7-da8bb475e299/windows-could-not-prepare-the-partition-selected-for-installation?forum=winserversetup

Share this post


Link to post
Share on other sites
haris_sane69

Issue resolved now

Here is the working script:

<?xml version="1.0" encoding="UTF-8"?>

-<unattend xmlns="urn:schemas-microsoft-com:unattend">


-<settings pass="windowsPE">


-<component language="neutral" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" versionScope="nonSxS" publicKeyToken="31bf3856ad364e35" processorArchitecture="amd64" name="Microsoft-Windows-International-Core-WinPE">


-<SetupUILanguage>

<UILanguage>en-GB</UILanguage>

</SetupUILanguage>

<InputLocale>4009:00004009</InputLocale>

<SystemLocale>en-GB</SystemLocale>

<UILanguage>en-GB</UILanguage>

<UserLocale>en-GB</UserLocale>

<UILanguageFallback>en-US</UILanguageFallback>

</component>


-<component language="neutral" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" versionScope="nonSxS" publicKeyToken="31bf3856ad364e35" processorArchitecture="amd64" name="Microsoft-Windows-Setup">


-<DiskConfiguration>


-<Disk wcm:action="add">


-<CreatePartitions>


-<CreatePartition wcm:action="add">

<Extend>true</Extend>

<Order>5</Order>

<Type>Primary</Type>

</CreatePartition>


-<CreatePartition wcm:action="add">

<Order>4</Order>

<Type>Primary</Type>

<Size>134103</Size>

</CreatePartition>


-<CreatePartition wcm:action="add">

<Order>3</Order>

<Size>16</Size>

<Type>MSR</Type>

</CreatePartition>


-<CreatePartition wcm:action="add">

<Order>2</Order>

<Size>100</Size>

<Type>EFI</Type>

</CreatePartition>


-<CreatePartition wcm:action="add">

<Order>1</Order>

<Size>450</Size>

<Type>Primary</Type>

</CreatePartition>

</CreatePartitions>


-<ModifyPartitions>


-<ModifyPartition wcm:action="add">

<Format>NTFS</Format>

<Letter>D</Letter>

<Order>5</Order>

<PartitionID>5</PartitionID>

</ModifyPartition>


-<ModifyPartition wcm:action="add">

<Format>NTFS</Format>

<Letter>C</Letter>

<Order>4</Order>

<PartitionID>4</PartitionID>

</ModifyPartition>


-<ModifyPartition wcm:action="add">

<Order>3</Order>

<PartitionID>3</PartitionID>

</ModifyPartition>


-<ModifyPartition wcm:action="add">

<Format>FAT32</Format>

<Order>2</Order>

<PartitionID>2</PartitionID>

</ModifyPartition>


-<ModifyPartition wcm:action="add">

<Format>NTFS</Format>

<Order>1</Order>

<PartitionID>1</PartitionID>

<TypeID>DE94BBA4-06D1-4D40-A16A-BFD50179D6AC</TypeID>

</ModifyPartition>

</ModifyPartitions>

<DiskID>0</DiskID>

<WillWipeDisk>true</WillWipeDisk>

</Disk>

</DiskConfiguration>


-<ImageInstall>


-<OSImage>


-<InstallTo>

<DiskID>0</DiskID>

<PartitionID>4</PartitionID>

</InstallTo>

</OSImage>

</ImageInstall>


-<UserData>


-<ProductKey>

<Key>VK7JG-NPHTM-C97JM-9MPGT-3V66T</Key>

</ProductKey>

<AcceptEula>true</AcceptEula>

<Organization>dell</Organization>

</UserData>

</component>

</settings>

<cpi:offlineImage xmlns:cpi="urn:schemas-microsoft-com:cpi" cpi:source="wim:c:/win10/sources/install.wim#Windows 10 Pro"/>

</unattend>

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...