Jump to content
Sign in to follow this  
Karlston

(How to) Disable auto-invites to combat Google Calendar Spam

Recommended Posts

Karlston

Disable auto-invites to combat Google Calendar Spam

Google Calendar spam is not a new phenomenon; it has plagued Google Calendar users for years and spam seems to come and go in waves. Recently, users started to report an increase in Google Calendar spam. Spam comes in many forms but the two main categories fall into advertising and outright malicious messages.

 

Google Calendar customers who did not receive spam invites up until now may wonder how that invite got accepted in first place; it is easy to explain: Google Calendar has a feature that automatically adds invitations to Calendar.

 

All an attacker needs to do is send you an invite using the right format and et voila, the invite becomes visible in Google Calendar.

 

What makes this particularly problematic, besides the fact that this feature is opt-out and not opt-in, is that the mobile Google Calendar application does not even have the option to disable this.

Here is how you disable auto-invites in Google Calendar

google calendar disable auto invites

  1. Open the Google Calendar application in a browser on a desktop PC. If you try to open the Calendar website on a mobile device you may be redirected to the Calendar application automatically.
  2. Open the Settings menu when the website has loaded and select Settings from the context menu (you need to sign-in to your Google account).
  3. Select Event Settings from the menu on the left or scroll down to the Event settings section on the page.
  4. The setting "Automatically add invitations" needs to be adjusted. It is set to Yes by default which means that invitations are accepted automatically; this is the source of the spam that you receive on Google Calendar.
  5. Switch the value of the setting to "No, only show invitations to which I have responded".

google calendar disable show declined events

 

If you still receive spam after making that change, follow the instructions below:

  1. Open the Google Calendar settings again on the desktop.
  2. Scroll down to the "View options" section or click on View Options in the sidebar to jump to the section on activation.
  3. Uncheck the "show declined events" option; this hides declined events in Calendar automatically.
  4. Scroll down to Events from Gmail.
  5. Disable "Automatically add events from Gmail to my Calendar".

Note that you may need to disable the "show declined events" on the mobile Calendar application as well if you still see those there and use it.

 

Disabling automatic invites could make things a little less comfortable for Google customers who share calendars with others and used to use the auto-invite system in the past.

 

 

 

Source: Disable auto-invites to combat Google Calendar Spam (gHacks - Martin Brinkmann)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...