Jump to content
Sign in to follow this  
Knightmare

Game / Music Audio Mutes When Changing Output Device

Recommended Posts

Knightmare

Anyone else having this issue? I was playing a game and my bluetooth headphones made a beep sound like they were going to die, so I turned them off and switched over to my speakers for sound, but when I turned on the speakers, the game music was not playing in the background. I did a sound test and I could hear the test, but I couldn't get the game audio to come back. I have been trying to update my bluetooth driver, but the latest drivers don't seem to be compatible with my setup for some reason. I uninstalled the latest bluetooth driver update and went back to whichever version that Windows gives me when I do a search for updates automatically online. Everything works fine until I change the output. I'm using a USB Bluetooth dongle, so I'm not sure if that is going bad. I have noticed that the light on the dongle stays on all the time, which I thought that it went off when I turned off my headset. I have disabled exclusive mode in all of my sound devices. This issue was happening in Musicbee whenever I would click out of Musicbee / open Streamlabs OBS, the sound from Musicbee would mute, even though the music was still playing and my OBS was detecting the sound. Hopefully I did an okay job of describing my issue.

Share this post


Link to post
Share on other sites
jbleck
  • You should stop any audio before changing the output device for safety (usually it changes with no problem even if u don't, but still...)
  • Check to see if the audio output in the app / game settings u're running is "Primary Sound Driver". If this is the case the app / game should follow your Windows instructions.
  • Put your USB dongle in a safe USB port... don't touch / move / hit it.
  • See that your speakers are powered on.

 

Before Windows was able to switch the output audio device while audio was on, i used (still do) WinAmp with QO Labs AudioBurst FX as the default output plugin... It's a test to see if it's Windows's issue or not.

Edited by jbleck

Share this post


Link to post
Share on other sites
Knightmare
9 minutes ago, jbleck said:
  • You should stop any audio before changing the output device for safety (usually it changes with no problem even if u don't, but still...)
  • Check to see if the audio output in the app / game settings u're running is "Primary Sound Driver". If this is the case the app / game should follow your Windows instructions.
  • Put your USB dongle in a safe USB port... don't touch / move / hit it.
  • See that your speakers are powered on.
  • I'll note that for next time
  • The game doesn't have those kinds of settings, so I'm assuming that it uses the primary by default
  • I think it's in a safe port. I'm not close enough to the computer to bump it and it was working fine when I first got it.
  • The speakers weren't turned on but when I did turn them on, I couldn't hear the game but I could hear the sound test.
6 minutes ago, Reefa said:

Thread moved from software chat..

Sorry 😊

Share this post


Link to post
Share on other sites
jbleck
2 minutes ago, Knightmare said:

when I did turn them on, I couldn't hear the game but I could hear the sound test.

Restart your game... the audio should switch then.

 

Too bad MS can't find the right solution for this issue... i too am getting it every once in a while.

Share this post


Link to post
Share on other sites
Reefa
5 minutes ago, Knightmare said:

Sorry 😊

 

Very kind of you mate but there's no worries i just thought it fitted better here..

Share this post


Link to post
Share on other sites
sefton22

i've had a similar issue that the default audio driver switches over to what it thinks is a MS headset, only its an Xbox controller.

 

i've only recently started to use AudioSwitcher, it might be worth checking to see if it can solve your issue 

 

"Audio Switcher makes switching between sound devices trivial. No longer do you have to go into Control Panel or the Windows® Sound options, instead there is an easy to access icon, or even hotkeys."

Edited by sefton22

Share this post


Link to post
Share on other sites
Knightmare
3 hours ago, jbleck said:

Restart your game... the audio should switch then.

 

Too bad MS can't find the right solution for this issue... i too am getting it every once in a while.

Restarting the game fixes it, but I'm looking for a more permanent solution so that it doesn't happen at all.

Share this post


Link to post
Share on other sites
Knightmare
6 hours ago, sefton22 said:

i've had a similar issue that the default audio driver switches over to what it thinks is a MS headset, only its an Xbox controller.

 

i've only recently started to use AudioSwitcher, it might be worth checking to see if it can solve your issue 

 

"Audio Switcher makes switching between sound devices trivial. No longer do you have to go into Control Panel or the Windows® Sound options, instead there is an easy to access icon, or even hotkeys."

Didn't Windows 10 integrate this into the volume icon?

Share this post


Link to post
Share on other sites
jbleck
11 minutes ago, teodz1984 said:

nope... not device switching 

yep, they did... but it is not flawless.

03IVSWD.png

Share this post


Link to post
Share on other sites
jbleck
5 minutes ago, teodz1984 said:

not automatic switching or fallback switching if primary device disconnects

automatic would be a bad thing... immagine someone watching porn with a headset and then that fails and the auto thing would go to your 7.1 Dolby Atmos set with max volume :P

 

 

btw... u are again trying to steer (as u did on another topic a while ago) this... are u a woman?

Edited by jbleck

Share this post


Link to post
Share on other sites
teodz1984

ops problem related  to device fallback.. 

 

not my problem if you are doing porn and hiding it.. normal person would be  turn down the volume.. unless you get a kick out of it

Edited by teodz1984

Share this post


Link to post
Share on other sites
Knightmare
7 hours ago, jbleck said:

automatic would be a bad thing... immagine someone watching porn with a headset and then that fails and the auto thing would go to your 7.1 Dolby Atmos set with max volume :P

 

 

btw... u are again trying to steer (as u did on another topic a while ago) this... are u a woman?

Good point. I can't have something like this happening while I'm watching my porn. #sarcasm 😏

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...