Jump to content

Welcome to nsane.forums

Welcome to nsane.forums, like most online communities you need to register to view parts of our community or to make contributions, but don't worry: this is a free and simple process that requires minimal information. Be a part of nsane.forums by signing in or creating an account.

  • Access special members only forums
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates

 

Please note: Unfortunetely due to some server side issues, registration via Hotmail / Outlook email addresses do not work, members are requested to use some other email addresses like Gmail to register here.


virge

Autochk program not found - skipping AUTOCHECK Windows Fix

Recommended Posts

virge    1,631
virge

Windows XP, 7,8 and 10 boot crash issue - "autochk program not found, skipping autocheck" .

 

Windows does this autocheck routine upon bootup to check for a dirty bit, ff it finds it, Windows will not load and you will get the message of "autochk program not found, skipping autocheck". Once this happens, there is no way that I know of to fix it. Running the usual 'bootrec /fixmbr' or 'bootrec /fixboot' won't do anything as the issue has nothing to do with the master boot record, partition table or your hard drive in general.

 

The only resolve is to reinstall the operating system, even safe mode won't help here. This issue hit two of my friend's pc's yesterday and it's no fun having to reinstall from scratch, especially when most people never back up. 

 

The problem is a routine registry check for what Microsoft calls a dirty bit, flag > yes then Windows will not boot, flag < no, Windows is allowed to boot.

 

There are many articles about the autochk issue, most of them from several years ago and with the wrong information on how to resolve it. I have looked through many web sites, all with ridiculous resolves.

 

Here is how to fix it before Windows crashes on you. 

 

Check if your drive is dirty or not. Run this command with admin rights. x=drive letter, ex: fsutil dirty query c:

fsutil dirty query x:

Even if Windows says drive is NOT dirty, I would still make this change.

 

Default Setting in Windows 10 Pro x64

Untitled.png

 

Locate this registry key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager to find the entry

 

Run this command with admin rights. x=drive letter, ex: chkntfs /x c:

chkntfs /x x: 

If you have multiple partitions/drives, enter chkntfs /x c: d: e: f:  < -- place each drive letter on the same line with space

Details:https://support.microsoft.com/en-us/help/160963/chkntfs-exe-what-you-can-use-it-for and https://technet.microsoft.com/en-us/library/bb490877.aspx

 

Changed Setting in Windows 10 Pro x64

Remove chkdsk

 

According to Microsoft, the autocheck feature is to prevent malicious rogue software from corrupting your computer. The idea is to stop Windows from booting before the problem gets worse. Unfortunately, when this message occurs, there is no fix, other than the reinstall. I have seen this issue occur on a few pc's now with hardly any applications installed, all variants of Windows. Hope this helps.

 

Article: https://www.raymond.cc/blog/disable-or-stop-auto-chkdsk-during-windows-startup/view-all/

Article: http://www.hightechdad.com/2013/04/25/how-to-stop-chkdsk-from-running-on-every-boot-up/

Edited by virge
fixed typos
  • Like 2

Share this post


Link to post
Share on other sites
neofita    441
neofita

It also happened to me this morning.
Obviously I had to reinstall
:rant:

Share this post


Link to post
Share on other sites
Pete 12    1,249
Pete 12

I have only this key BootExecute , nothing else , its empty key..........??   :mellow: 

BootExecute-empty key.jpg

Edited by Pete 12

Share this post


Link to post
Share on other sites
eurobyn    217
eurobyn

could this be a solution ? try to boot from a bootable windows pe cd and use a register editor pe so you can make changes to the registry ?

  • Like 1

Share this post


Link to post
Share on other sites
J.D    189
J.D

In win7 x64 I have this 

 

autoche
R}x ¡¢£¤¥¦§¨©ª«¬­®¯°±²³´µ¶·¸¹º»¼½¾¿ÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖ×ØÙÚÛÜÝÞßÀÁÂÃÄÅÆÇÈÉÊËÌÍÎÏÐÑÒÓÔÕÖ÷ØÙÚÛÜÝÞxÌ
autocheck autochk *
:blink:

Share this post


Link to post
Share on other sites
Pete 12    1,249
Pete 12

And............do you think thats ok..............?  <_<

Share this post


Link to post
Share on other sites
virge    1,631
virge
1 hour ago, Pete 12 said:

I have only this key BootExecute , nothing else , its empty key..........??   :mellow: 

Try running the command of  chkntfs /x c:  and see if that makes any changes. Backup your os/data before doing so.

Share this post


Link to post
Share on other sites
J.D    189
J.D
48 minutes ago, Pete 12 said:

And............do you think thats ok..............?  <_<

Encrypted ? :blink:  by Zemana Anti-logger ? 

Share this post


Link to post
Share on other sites
Pete 12    1,249
Pete 12

I get " c is not a valid drive specification."  after CMD chkntfs /x c..............?

And bootexecute still empty.........( no info in this key )

After inserting " autocheck autochk* " in this empty key , I got same result with " chkntfs /x c " ............!

Edited by Pete 12

Share this post


Link to post
Share on other sites
J.D    189
J.D
4 minutes ago, Pete 12 said:

I get " c is not a valid drive specification."  after CMD chkntfs /x c..............?

You need the :  after the C

All it tells me is The File System is NTFS :rolleyes: but I know that..... I copied / pasted from post #1 and entered it as a Command prompt  (Run as Administrator)

Share this post


Link to post
Share on other sites
Pete 12    1,249
Pete 12

" You need the :  after the C " ....ok, so I did , still nothing happens............!

Ho, after reboot I got " "autochk program not found, skipping autocheck" " .............not good , I guess..!

 

After removing the " autocheck autochk* " from the reg-key ( BootExecute ) this " "autochk program not found, skipping autocheck"  did not show up after reboot............

Edited by Pete 12
  • Like 1

Share this post


Link to post
Share on other sites
VIKTOR PAVEL    2,243
VIKTOR PAVEL

Some times modify  HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager is not sufficient

you must modify also:

HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Session Manager
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Control\Session Manager

 

Also responsible for this issue is

- malware mostly use this strings to wright some thing

- anti-malware too can remove files from system32 but not remove string from registry

- some programs write to this string and after uninstall they remove files but not remove string in registry

- Diskeeper Bootime defrag

and check if you still have mountmgr.sys File in Windows\System32\Drivers (in this case not need reinstall - just copy file from good system or cd)

 

Normal state is only autocheck autochk * - no other thing with it (unless you use program who need exclusive access to volumes)

Share this post


Link to post
Share on other sites
Pete 12    1,249
Pete 12

Have checked these keys, they are all present...........still we got   "autochk program not found, skipping autocheck "  after reboot............!

Share this post


Link to post
Share on other sites
VIKTOR PAVEL    2,243
VIKTOR PAVEL
3 hours ago, Pete 12 said:

" You need the :  after the C " ....ok, so I did , still nothing happens............!

Ho, after reboot I got " "autochk program not found, skipping autocheck" " .............not good , I guess..!

 

After removing the " autocheck autochk* " from the reg-key ( BootExecute ) this " "autochk program not found, skipping autocheck"  did not show up after reboot............

 

21 minutes ago, Pete 12 said:

Have checked these keys, they are all present...........still we got   "autochk program not found, skipping autocheck "  after reboot............!

 

two contradictory reply! i am not understand!

Share this post


Link to post
Share on other sites
Pete 12    1,249
Pete 12

After checking these keys ( they are all present ), I made CMD ; chkntfs /x c:

Then during booting , I got  "autochk program not found, skipping autocheck " , and this message appears after every reboot.

When removing the " autocheck autochk* " from the reg-key ( BootExecute ) , this message does not appear anymore.

 

So remains the question how to do a disk-check on my SSD ?

 

Share this post


Link to post
Share on other sites
VIKTOR PAVEL    2,243
VIKTOR PAVEL
36 minutes ago, Pete 12 said:

So remains the question how to do a disk-check on my SSD ?

 

safe is use built in Windows Instrumentation Command Line Tool

open command prompt and type wmic
type diskdrive get status and press Enter key

if you have result OK no need other things coz SSD controller take care of your SSD for other tasks

 

many users say not safe use other command line tools

S.M.A.R.T tools is also not report exact state of SSD's

 

  • Like 2

Share this post


Link to post
Share on other sites
Pete 12    1,249
Pete 12

Very good Viktor , CMD gave me , 7 times , OK !

This CMD wmic/diskdrive get status is the solution..................:D !

  • Like 1

Share this post


Link to post
Share on other sites
jayesh30202    1,020
jayesh30202
10 hours ago, VIKTOR PAVEL said:

 

safe is use built in Windows Instrumentation Command Line Tool

open command prompt and type wmic
type diskdrive get status and press Enter key

if you have result OK no need other things coz SSD controller take care of your SSD for other tasks

 

many users say not safe use other command line tools

S.M.A.R.T tools is also not report exact state of SSD's

 

So i guess the below screenshot from my system should do just fine

 

Screenshot_3.png

  • Like 1

Share this post


Link to post
Share on other sites
Pete 12    1,249
Pete 12

I suppose so, coz you have the same results as I have................ !

( again a reason for feeling happy :D )

  • Like 1

Share this post


Link to post
Share on other sites
Israeli_Eagle    601
Israeli_Eagle

1. Never had such a weird problems.

2. A system restore would fix it for sure.

3. Restore points should created anyway daily, script as Scheduler Task for example.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×